When creating a subclass of the Spark ItemRenderer and using states. The default state should be named “default” rather than “normal”. Initially I had used “normal” and found that state logic was breaking down when setting the currentState via a ClassFactory’s property definition. I believe the “normal” name is a carry over from borrowed state names in the ButtonSkin classes.
…. unless for some reason you are extending a SparkSkin and see an explicitly defined state with the name “normal”.